Freerails Home 
Home Search search Menu menu Not logged in - Login | Register
Freerails > Model Railroad Forums > O Scale > Opinions on this loco: Pola Maxi 677 ATSF O Scale 2 Rail 0-6-0

Because of non-railroad abuse of the site, new members MUST use their first names (at least) to join NO EXCEPTIONS!

Opinions on this loco: Pola Maxi 677 ATSF O Scale 2 Rail 0-6-0
 Moderated by: Reg H Page:  First Page Previous Page  1  2   
New Topic Reply Printer Friendly
 Rate Topic 
AuthorPost
 Posted: Sat Oct 22nd, 2016 11:32 pm
  PMQuoteReply
11th Post
Robert Comerford
Registered
 

Joined: Thu Feb 14th, 2013
Location: Glen Innes, Australia
Posts: 578
Status: 
Offline
:)

That is a Lima coupler installed at the front. I donate them to a friend.

Would there be much room left for the rx/esc and battery when the motor is installed?

cheers
 BobC

Back To Top

 Posted: Sun Dec 4th, 2016 05:50 pm
  PMQuoteReply
12th Post
Tim H
Registered
 

Joined: Sun Dec 14th, 2014
Location: United Kingdom
Posts: 157
Status: 
Offline
They are really awful models, bad motors and even worse drive systems. The Allan valvegear does not work correctly and is more fragile than a politician's promise.

In a couple of years, Lenz will sell the definitive version with DCC bells, whistles and everything you ever wanted for less than 50% of a creaky old brass model.

Do not buy this POS.

Tim



____________________
Tim H
http://timhalesblog.blogspot.co.uk
Back To Top

 Posted: Sun Dec 4th, 2016 10:47 pm
  PMQuoteReply
13th Post
Robert Comerford
Registered
 

Joined: Thu Feb 14th, 2013
Location: Glen Innes, Australia
Posts: 578
Status: 
Offline
Looks like someone fitted a Triang Big Big Train coupler to one end.
cheers
Bob

Back To Top


 Current time is 08:37 am
Page:  First Page Previous Page  1  2   

Freerails > Model Railroad Forums > O Scale > Opinions on this loco: Pola Maxi 677 ATSF O Scale 2 Rail 0-6-0
Top



UltraBB 1.172 Copyright © 2007-2016 Data 1 Systems